[Shorewall-users] Shell Requirements for Shorewall 1.4.6

Tom Eastep teastep at shorewall.net
Tue Jul 1 23:16:41 PDT 2003


On Tue, 2003-07-01 at 14:23, Steve Herber wrote:
> I ran the script on my RH 9.0 system and the default sh is linked to bash, 
> so the test worked.  Using ash shellcheck.sh it failed as you mentioned.
> 

For some reason, the RH 9.0 version of ash doesn't support "^" (XOR) in
arithmetic expressions.


> I wondered why you brought this up without a reference to the earlier thread
> about faster startup with ash vs. bash.
> 

I'm afraid that I'm having a bit of a disorganized day. I have made the
Bering version of ash available for download in case folks wish to use
that (ftp://shorewall.net/pub/shorewall/misc/ash.gz). That's the shell
that I'm using in conjunction with the SHOREWALL_SHELL option in
shorewall.conf that's included in the latest snapshot.

I've moved that shell to /bin/Bering_ash and have set
SHOREWALL=SHELL=/bin/Bering_ash in shorewall.conf.

> Another dark corner of shell hell to stumble over.

Nod. It shouldn't affect anyone using bash but for those using
light-weight Bourne Shell derivatives, there may be problems. I'm trying
to alert people well in advance to eliminate as many surprises as
possible.

Thanks,
-Tom
-- 
Tom Eastep    \ Shorewall - iptables made easy
Shoreline,     \ http://www.shorewall.net
Washington USA  \ teastep at shorewall.net



More information about the Shorewall-users mailing list