[Shorewall-users] No Accounting?

Andrey Paskal app at altlinux.ru
Sat Dec 6 19:30:19 PST 2003


Hello!
I'm a novice level shorewall user.
I just tried to setup traffic accounting for single interface system 
http://www.shorewall.net/Accounting.html

When setuped and restarted by stop/start and some web browsing activity from 
fw machine
shorewall show accounting web      shows only zeros

[root at happ shorewall]# shorewall show accounting
Shorewall-1.4.8 Chain accounting at happ - Сбт Дек  6 19:05:37 MSK 2003

Counters reset Sat Dec  6 18:00:42 MSK 2003

Chain accounting (3 references)
 pkts bytes target     prot opt in     out     source               
destination
    0     0 web        tcp  --  eth0   *       0.0.0.0/0            0.0.0.0/0          
tcp dpt:80
    0     0 web        tcp  --  *      eth0    0.0.0.0/0            0.0.0.0/0          
tcp spt:80
    0     0 web        tcp  --  eth0   *       0.0.0.0/0            0.0.0.0/0          
tcp dpt:443
    0     0 web        tcp  --  *      eth0    0.0.0.0/0            0.0.0.0/0          
tcp spt:443

[root at happ shorewall]# shorewall show accounting web
Shorewall-1.4.8 Chains accounting web at happ - Сбт Дек  6 19:23:02 MSK 2003

Counters reset Sat Dec  6 18:00:42 MSK 2003

Chain accounting (3 references)
 pkts bytes target     prot opt in     out     source               
destination
    0     0 web        tcp  --  eth0   *       0.0.0.0/0            0.0.0.0/0          
tcp dpt:80
    0     0 web        tcp  --  *      eth0    0.0.0.0/0            0.0.0.0/0          
tcp spt:80
    0     0 web        tcp  --  eth0   *       0.0.0.0/0            0.0.0.0/0          
tcp dpt:443
    0     0 web        tcp  --  *      eth0    0.0.0.0/0            0.0.0.0/0          
tcp spt:443
Chain web (4 references)
 pkts bytes target     prot opt in     out     source               
destination
    0     0            all  --  eth0   *       0.0.0.0/0            0.0.0.0/0
    0     0            all  --  *      eth0    0.0.0.0/0            0.0.0.0/0
[root at happ shorewall]#

please, give me advise 
what is wrong in my case

I'm using RedHat 9
[root at happ shorewall]# uname -a
Linux happ 2.4.20-8 #1 Thu Mar 13 17:54:28 EST 2003 i686 i686 i386 GNU/Linux
[root at happ shorewall]# rpm -qa |grep iptables
iptables-1.2.7a-2
[root at happ shorewall]# rpm -qa |grep shore
shorewall-1.4.8-1
[root at happ shorewall]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:40:F4:76:8D:7A
          inet addr:192.168.0.232  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:20424 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19029 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:7792841 (7.4 Mb)  TX bytes:1918007 (1.8 Mb)
          Interrupt:11 Base address:0xd000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:407 errors:0 dropped:0 overruns:0 frame:0
          TX packets:407 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:742268 (724.8 Kb)  TX bytes:742268 (724.8 Kb)


Thank you
Andrey Paskal


More information about the Shorewall-users mailing list