[Shorewall-users] cable modem trouble

Tom Eastep teastep@shorewall.net
Mon, 22 Apr 2002 06:02:35 -0700 (PDT)


On Mon, 22 Apr 2002, Lino.Catucci@nuon.com wrote:

> Hello everybody,
> 
> I'm a new user of the shorewall firewall and I've a hard problem getting the
> firewall working.
> Can someone please can help me ?
> Here is my situation:
> 
> I've a RedHat linux server with 2 NIC's. One is connected to the internet
> with a cable modem with a dhcp ip adress (24.132.59.69) but I always get
> this address so it's almost a static one,  and the other one is eth1
> connected to my lan with ipaddress 192.168.0.5
> My linux server is used as a firewall and as a webserver and mail server
> (Lotus Domino) and I also want to use my server as an internet gateway
> (Masquerading) for my other pc's in my lan.
> 
> In my lan I've two win2000 machine one workstation and one laptop with
> ipaddresses : 192.168.0.1 and 192.168.0.4 
> I've downloaded and installed the quick two-interfaces.tgz file and I've
> changed the files to my needs.
> But there are still problems with internet access from my 2 windows2000
> machines. Also I can't receive or send any email, outgoing mail is pending
> and incoming mail get bounced.
> It looks like there's now internet connection allowed or there is something
> misconfigurated.
> 
> I've attached my files, who I've changed.
> Could some please help me with this problem?
>

First of all, you have used the parameterized samples which are no longer 
supported (see http://www.shorewall.net -- News article titled 
"Parameterized Samples Withdrawn" dated April 8 ). 

Here are a couple of clues though:

1) FW_UDP_OUT_PORTS=none

How do you expect your firewall to be able to resolve DNS names? Possibly 
the reason that mail doesn't get delivered and that incoming mail bounces?

2) Have you set the default gateway on the Windoze systems to 192.168.0.5?
 

-Tom 
--
Tom Eastep    \ Shorewall - iptables made easy
AIM: tmeastep  \ http://www.shorewall.net
ICQ: #60745924  \ teastep@shorewall.net