[Shorewall-newbies] No access from loc to net

Tom Eastep teastep at shorewall.net
Sat Mar 13 07:18:48 PST 2004


On Saturday 13 March 2004 07:10 am, Tom Eastep wrote:
> On Saturday 13 March 2004 02:02 pm, motiv8d wrote:
> > I have just setup shorewall. I seem to have a problem with forwarding.
> > When I am using the firewall box, I can connect to the net, ping etc.
> > When I am using a pc on the local network I cannot ping externally or
> > access the internet. I can however ping the fw.
> > I noticed when shorewall was starting that the 3 zones were all listed
> > as 0.0.0.0/0 so I added entries in ./shorewall/hosts for the correct
> > zones. I am not sure if I have done the right thing there or not,
> > however, it didnt solve my problem. I still cannot get access to the net
> > from loc.
>
> Now please start over and follow the instructions at
> http://www.shorewall.net/two-interface.htm.
>

Please disregard my suggestion -- it appears that you have a three-interface 
setup and it also appears that you tried to follow the three-interface guide. 

Using the hosts file was not the correct approach -- you should have set up 
your zones using the interfaces file (which you haven't forwarded)

Try setting up the interfaces file as described in the three-interface guide 
and see if it doesn't work better for you.

-Tom
-- 
Tom Eastep    \ Nothing is foolproof to a sufficiently talented fool
Shoreline,     \ http://shorewall.net
Washington USA  \ teastep at shorewall.net




More information about the Shorewall-newbies mailing list