[Shorewall-newbies] Change of eth0 ip address

Tom Eastep teastep at shorewall.net
Mon Feb 9 07:54:14 PST 2004


On Monday 09 February 2004 07:40 am, Garrett Johnson wrote:
> Not sure if this is a Shorewall problem but....
>
> We're setting up a new proxy/gateway with Shorewall.  We have a multihomed
> 3 interface network with a eth0 10.1.1.0 network and a eth1 10.1.10.0
> network and external is connected through a router at 192.168.7.0.  We've
> been running this setup within MIS for about a week and everything has been
> working great.  We decided to go live with the new proxy so we downed the
> old proxy on 10.1.1.1 and changed the ip of the new proxy 10.1.1.55 to
> 10.1.1.1.  After doing so DNS would not resolve through the new proxy
> server but I was getting no reject notices on the shorewall status page. 
> The internet was still working as we have a few external machines running
> and they were working.  I grepped the shorewall files and 10.1.1.55 was not
> in any of them.  I restarted shorewall.  I restarted the shorewall service.
>  I rebooted.  None of these changed the fact I couldn't get DNS.  I suspect
> the routing/gateway on the machine but everything looks good and when I do
> a traceroute it goes right to the internet.  I don't even see the proxy in
> the traceroute which I found odd.  I am Masquerading though so I think this
> is the reason why.  I also seem to be going to a strange 172. address. 
> Hopefully this is enough information to provide a clue.

I'm completely lost as to what problem you are reporting, let alone being able 
to offer a solution.

-Tom
-- 
Tom Eastep    \ Nothing is foolproof to a sufficiently talented fool
Shoreline,     \ http://shorewall.net
Washington USA  \ teastep at shorewall.net




More information about the Shorewall-newbies mailing list